Ansible-core: unsafe tagging bypass via hostvars object in ansible-core
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.18.1rc1, 2.17.7rc1, 2.16.14rc1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
A flaw was found in Ansible-Core. This vulnerability allows attackers to bypass unsafe content protections using the hostvars object to reference and execute templated content. This issue can lead to arbitrary code execution if remote data or module outputs are improperly templated within playbooks.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- ansible-core
through 2.18.0
- ansible-automation-platform/ansible-builder-rhel8
Version range not reported
- ansible-automation-platform/ansible-builder-rhel9
Version range not reported
- ansible-automation-platform/ee-29-rhel8
Version range not reported
- ansible-automation-platform/ee-minimal-rhel8
Version range not reported
- ansible-automation-platform/ee-minimal-rhel9
Version range not reported
- ansible-core
Version range not reported
- ansible-core
Version range not reported
- ansible-core
Version range not reported
- rhelai1/bootc-azure-nvidia-rhel9
Version range not reported
- rhelai1/bootc-nvidia-rhel9
Version range not reported
- ansible-corePyPI
From 2.18.0b1 · fixed in 2.18.1rc1
- ansible-corePyPI
From 2.17.0b1 · fixed in 2.17.7rc1
- ansible-corePyPI
fixed in 2.16.14rc1
- ansible-corePyPI
fixed in 2.16.14rc1; From 2.17.0b1 · fixed in 2.17.7rc1; From 2.18.0b1 · fixed in 2.18.1rc1