Skip to main content
← All vulnerabilities
CVE-2024-10979

PostgreSQL PL/Perl environment variable changes execute arbitrary code

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 17.1, 16.5, 15.9, 14.14, 13.17, and 1 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Incorrect control of environment variables in PostgreSQL PL/Perl allows an unprivileged database user to change sensitive process environment variables (e.g. PATH). That often suffices to enable arbitrary code execution, even if the attacker lacks a database server operating system user. Versions before PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21 are affected.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • n/a PostgreSQL

    From 17 · fixed in 17.1; From 16 · fixed in 16.5; From 15 · fixed in 15.9; From 14 · fixed in 14.14; From 13 · fixed in 13.17; fixed in 12.21

References 1

postgresql.org