Skip to main content
← All vulnerabilities
CVE-2024-10977

PostgreSQL libpq retains an error message from man-in-the-middle

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 17.1, 16.5, 15.9, 14.14, 13.17, and 1 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Client use of server error message in PostgreSQL allows a server not trusted under current SSL or GSS settings to furnish arbitrary non-NUL bytes to the libpq application. For example, a man-in-the-middle attacker could send a long error message that a human or screen-scraper user of psql mistakes for valid query results. This is probably not a concern for clients where the user interface unambiguously indicates the boundary between one error message and other text. Versions before PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21 are affected.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • n/a PostgreSQL

    From 17 · fixed in 17.1; From 16 · fixed in 16.5; From 15 · fixed in 15.9; From 14 · fixed in 14.14; From 13 · fixed in 13.17; fixed in 12.21

References 1

postgresql.org