Skip to main content
← All vulnerabilities
CVE-2024-10727

Cross-Site Scripting (XSS) in phpipam/phpipam

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.7.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

A reflected cross-site scripting (XSS) vulnerability exists in phpipam/phpipam versions 1.5.0 through 1.6.0. The vulnerability arises when the application receives data in an HTTP request and includes that data within the immediate response in an unsafe manner. This allows an attacker to execute arbitrary JavaScript in the context of the user's browser, potentially leading to full compromise of the user.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • phpipam phpipam/phpipam

    fixed in 1.7.0

References 2

huntr.com

GitHub · phpipam/phpipam