CVE-2023-6835GHSA-W7RX-824V-RGX5
Multiple WSO2 products have been identified as vulnerable due to lack of server-side input validation in the Forum feature, API rating could
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.2.0.16, 2.5.0.17, 2.6.0.24, 3.3.1.17
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Multiple WSO2 products have been identified as vulnerable due to lack of server-side input validation in the Forum feature, API rating could be manipulated.
Timeline
- CVE published
- Record last updated
Affected versions
- WSO2 WSO2 API Manager
From 2.2.0.0 · fixed in 2.2.0.16; From 2.5.0.0 · fixed in 2.5.0.17; From 2.6.0.0 · fixed in 2.6.0.24
- WSO2 WSO2 IoT Server
From 3.3.1.0 · fixed in 3.3.1.17
- org.wso2.carbon.apimgt:forumMaven
through 9.0.78