Skip to main content
← All vulnerabilities
CVE-2023-5967GHSA-XVQ6-H898-WCJ8

Denial of Service via crashing the Calls Plugin

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 7.8.12, 8.0.4, 8.1.3, 9.0.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Mattermost fails to properly validate requests to the Calls plugin, allowing an attacker sending a request without a User Agent header to cause a panic and crash the Calls plugin

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Mattermost Mattermost

    through 8.1.2; through 8.0.3; through 7.8.11

  • github.com/mattermost/mattermost-server/v6Go

    fixed in 7.8.12

  • github.com/mattermost/mattermost/server/v8Go

    From 8.0.0 · fixed in 8.0.4

  • github.com/mattermost/mattermost/server/v8Go

    From 8.1.0 · fixed in 8.1.3

  • github.com/mattermost/mattermost/server/v8Go

    From 9.0.0 · fixed in 9.0.1

References 1

mattermost.com