Skip to main content
← All vulnerabilities
CVE-2023-5763GHSA-2MW4-WJ8C-7F93

Glassfish remote code execution

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 7.0.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

In Eclipse Glassfish 5 or 6, running with old versions of JDK (lower than 6u211, or < 7u201, or < 8u191), allows remote attackers to load malicious code on the server via access to insecure ORB listeners.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Eclipse Foundation Glassfish

    From 6.0.0 · through 6.2.5; From 5.0 · through 5.1

  • org.glassfish.main.orb:orb-connectorMaven

    From 5.0.0 · fixed in 7.0.0

References 2

glassfish.org

gitlab.eclipse.org